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UL Certification Statements

This process control equipment to be supplied by Class2, LPS, limited power supply. 
dwOption-30 and -31 have not been evaluated for UL listing. 

 Conformity Statements
EMC Standard, EN 61326-1: 2006, Electrical Equipment for Measurement, Control and 

Laboratory Use. 
	 Emissions Class A, Commercial Equipment. 
	 Immunity Table 2, Industrial Equipment. 

LVD Standards, EN 61010-1: 2010, Safety Requirements for Electrical Equipment for 
Measurement, Control and Laboratory Use and;  

	 EN 61010-2-030: Particular Requirements for Testing and Measuring Circuits. 
smarty is an industrial controller designed for permanent installation by qualified professionals. 

If  it is used in a manner not specified herein the protection provided may be impaired. 
smarty and its packaging contain recyclable materials and a small rechargeable battery, classed 

as “portable”, that is permanently affixed to the underside of  the main circuit board.  The 
battery must be removed with wire-cutting pliers and separated for proper disposal. 
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This device complies with Part 15 of  the FCC Rules. Operation is subject to the following two conditions: (1)This 
device may not cause harmful interference, and (2)this device must accept any interference received, including 
interference that may cause undesired operation. 

This Class [A] digital apparatus complies with Canadian ICES-003.  Cet appareil numerique de la classe [A] est 
conforme à la norme NMB-003 du Canada. 

Warning! It is essential that you read and understand this entire manual and the entire contents of  the savvy 
software Help menu before proceeding with your installation and configuration. See page 6 for savvy installation 
instructions. For more information and to download manuals and software, go to www.driveweb.com or contact 
us. See page 12. 

Warning! Your use of  savvy software and drive.web devices may cause motors and machinery to power up 
with high Voltages or start or operate in an unexpected, dangerous or lethal way. It is essential that you are 
completely familiar with all of  the equipment and the system design before attempting to program or edit a 
program or connect to any live device. It is also essential that a risk assessment is conducted to identify hazards. 
Risks must be reduced to tolerable levels. 

Warning! You are entirely responsible for the configuration or use of  any drive.web product. By configuring 
or using these products you agree to indemnify and hold harmless Bardac Corporation, its employees, directors, 
officers, distributors, and resellers against the consequences of  your configuration or use of  the products. 

Warning! Information in this manual is subject to change without notice. You are responsible for verifying the 
proper operation of  your smarty. Special care must be taken after loading new firmware or installing new options.

Warning! Avoid permanent damage to your smarty, never exceed any min or max values.  Do not connect 
any smarty terminal to mains circuits. See page 5 for IO ratings. 
lwIP is incorporated into smarty firmware. lwIP Copyright (c) 2001-2004 Swedish Institute of  Computer Science. All rights reserved. 
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: 
1. Redistributions of  source code must retain the above copyright notice, this list of  conditions and the following disclaimer. 
2. Redistributions in binary form must reproduce the above copyright notice, this list of  conditions and the following disclaimer in the documentation and/or 
other materials provided with the distribution. 
3. The name of  the author may not be used to endorse or promote products derived from this software without specific prior written permission. 
THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT 
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN 
NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL 
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT 
LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN 
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 

Product Identification - smarty Models
smarty  is a programmable device using drive.web 

distributed control over Ethernet for industrial process 
automation. To program and use smarty you must get 
the savvy software tools from www.driveweb.com. 
See pages 6-9. 

Find smarty firmware version. Use savvy, Get Detailed 
Info from smarty contextual menu. Page 6.  

dw210 generic automation controller. 
dw212 for Optidrive E2 variable frequency drive. 
dw213 for Optidrive Plus open-loop vector drive. 
dw215 for Yaskawa YF7 inverter drive. 
dw216 for Optidrive HVAC variable-torque AC pump and fan drive. 

smarty Standard Features 
drive.web distributed process control. 
10/100Base-T(X) Ethernet. See page 4. 
8 flexible I/O: +25V, -13V 16-bit analog in, ±10V 

14-bit analog out, digital in.  
8 flexible I/O: 0-25V 16-bit analog in, 24V digital 

out, digital in. Pages 5 and 10. 
±10V control reference outputs, 20mA max. Page 5.  
Basic Control function block library.  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smarty Software Options  
Software options may be added using savvy. See page 8. 
04 ModbusTCP/IP - Slave/server. See page 12. 
05 Process Control - Recommended for most applications. 
06 Winder Control - Diameter Calc., Taper Tension, Torque Comp. 
10 Math - With internal 32-bit Calculator.  
11 Encoder Control - Requires 15 or 16 encoder inputs. 
25 EIP/PCCC - Slave/server. See page 12. 
26 savvyPanel - Operator station interface. See pages 8, 9. 
29 Solar - Calculates sun position azimuth and zenith. 
36 Motion Control - With Trapezoid Motion and Cam Profile. 

smarty Internal Hardware Options pages 11, 12 
Factory installed. All internal options are mutually exclusive.
15 Internal Incremental Encoder  
16 External Encoder i2i Port 
17 Isolated ModbusRTU Server - “Slave” , see separate 

manual, HG502421Iss2.  
18* Isolated ModbusRTU Server  -	“Slave”, see separate 

manual, HG502421Iss2 + i2i External Encoder Port. 
19* Dual ModbusRTU - Client and isolated server. 
23* Isolated ModbusRTU Client -	 “Master”, see separate 

manual, HG502421Iss2 + i2i External Encoder Port. 
24 Add Six Digital Inputs - See page 11. 
27 Frequency I/O - See separate manual, HG503056. 
28 Extended Digital I/O - See separate manual, HG503057. 
37* Stepper Controller with Event Inputs - Dual pulse and 

direction outputs, two event inputs. See manual, HG503431. 
38* Stepper Controller w/ Encoder Inputs -	Dual pulse and 

direction outputs with i2i port for remote encoder. See 
manual, HG503431. 

* These options are not available for drive-dedicated models, 
dw212, dw213, dw215, dw216. 

smarty External Module Options  
40 & 42 are mutually exclusive.  
45 & 46 are mutually exclusive & require 40 or 42. 
30 / 31 HVIO -	Isolator, 4 x 115VAC/230VAC digital in, 2 x NO 

relay out. See page 12. These options are not UL Listed.
40 Single Remote Encoder	 - 2V to 24V differential with 

marker. 5VDC, 200mA supply output. Two event inputs. 
42 Dual Remote Encoder - 2V to 24V differential. Two 

5VDC, 200mA supply outputs.  Two event inputs. 
45 Encoder Retransmit - EIA(RS)485 & 422 compliant. 
46 Encoder Retransmit - ±24V differential signal out.  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smarty Installation
smarty is designed for permanent installation by qualified 

professionals.
Install smarty in metal enclosure with no RF noise source. 
Weight - No hardware opts.-176g(6.2oz). W/ PoE & serial 

ports-213g(7.5oz). 
DIN rail mounting - Use 35x7.5mm rail per IEC 60715 or 

EN50022. 
Environment - UL/IEC Pollution Degree 2. 

Operating temperature, 0°C min., 50°C max.  
Storage temp, -20°C to 60°C. 
Altitude 3000m max.  
Humidity 95% max. non-condensing.  

Dimensions & clearances - Clearances must be provided 
to promote airflow. 

smarty Front Panel
USB port  - Peripheral-type micro-B jack. 
Ethernet port - MDI 8P8C, “RJ45” jack, 100baseTX and 10BaseT, 

Full Duplex, Auto Negotiation, Auto-MDIX, IEEE 802.3ab.  
Indicator LEDs in front panel.  

Power on - Green LED. 
Fault - Red LED. Check power supply, connect with savvy, 

or contact us at drive.web for more information. 
Ethernet link - Green LED indicates Ethernet connection. 
Ethernet activity - Yellow LED-Data transfer activity. 
100BaseTX - Green LED when 100BaseTX connection
Four yellow serial port LEDs  - See page 11. 
Earth - Do NOT use for 0V or control wiring. Observe 

local electrical codes and best wiring practices.

smarty HG502573Iss2.1	  www.driveweb.com                            Page # /124

Depth 120㎜	  
[4.72”]

Top & Bottom 
Clearances  

51㎜ (2”)

Width 23㎜ 
[0.91”]

Height 
104㎜ 
[4.09”]

 Sides Clearances 
25㎜ (1”)

Important Notes: 

Drawing is confidential for use in 

   creating labels for this order only.

Drawing is scaled 300% actual size.

All circles that appear, "white," 

   are no color (clear).

Background color to flood beyond 

   edges.

See attached drawing HJ502441 for 

   cutout dimensions.

Red color is 19 Fire Red.

Dark Gray is 29 Gray.

Background Gray is 27 Cool Gray.

99.00mm Ref.

Drawing No. Issue: Drawing Title: Drawn by: Property of:

GA502441 1 smarty front label art Ian Bardwell-Jones Bardac Corp.

drive.web
smarty

100

1

2

PoE

lOlOl

Important Notes: 

Drawing is confidential for use in 

   creating labels for this order only.

Drawing is scaled 300% actual size.

All circles that appear, "white," 

   are no color (clear).

Background color to flood beyond 

   edges.

See attached drawing HJ502441 for 

   cutout dimensions.

Red color is 19 Fire Red.

Dark Gray is 29 Gray.

Background Gray is 27 Cool Gray.

99.00mm Ref.

Drawing No. Issue: Drawing Title: Drawn by: Property of:

GA502441 1 smarty front label art Ian Bardwell-Jones Bardac Corp.

drive.web
smarty

100

1

2

PoE

lOlOl

Important Notes: 

Drawing is confidential for use in 

   creating labels for this order only.

Drawing is scaled 300% actual size.

All circles that appear, "white," 

   are no color (clear).

Background color to flood beyond 

   edges.

See attached drawing HJ502441 for 

   cutout dimensions.

Red color is 19 Fire Red.

Dark Gray is 29 Gray.

Background Gray is 27 Cool Gray.

99.00mm Ref.

Drawing No. Issue: Drawing Title: Drawn by: Property of:

GA502441 1 smarty front label art Ian Bardwell-Jones Bardac Corp.

drive.web
smarty

100

1

2

PoE

lOlOl

Important Notes: 

Drawing is confidential for use in 

   creating labels for this order only.

Drawing is scaled 300% actual size.

All circles that appear, "white," 

   are no color (clear).

Background color to flood beyond 

   edges.

See attached drawing HJ502441 for 

   cutout dimensions.

Red color is 19 Fire Red.

Dark Gray is 29 Gray.

Background Gray is 27 Cool Gray.

99.00mm Ref.

Drawing No. Issue: Drawing Title: Drawn by: Property of:

GA502441 1 smarty front label art Ian Bardwell-Jones Bardac Corp.

drive.web
smarty

100

1

2

PoE

lOlOl

Important Notes: 

Drawing is confidential for use in 

   creating labels for this order only.

Drawing is scaled 300% actual size.

All circles that appear, "white," 

   are no color (clear).

Background color to flood beyond 

   edges.

See attached drawing HJ502441 for 

   cutout dimensions.

Red color is 19 Fire Red.

Dark Gray is 29 Gray.

Background Gray is 27 Cool Gray.

99.00mm Ref.

Drawing No. Issue: Drawing Title: Drawn by: Property of:

GA502441 1 smarty front label art Ian Bardwell-Jones Bardac Corp.

drive.web
smarty

100

1

2

PoE

lOlOl

2008-03-18
HJ502441 smarty front label
Physical Dim.s & CutoutsBardac 40 Log Canoe Circle

Stevensville  MD 21666
(410) 604-3400 phone
(410) 604-3500 fax

info@bardac.com
www.bardac.com Ian Bardwell-Jonesissue 1 Bardac Confidential

drive.web
smarty

100

1

2

PoE

lOlOl

Reference Datum

Label Type 875

15 mil Clear VTP with 5 mil 3M #468 Adhesive

Three (3) Cut-outs

All Dimensions in mm ±0.1 mm

See attached drawing GA502441 for art and color information

http://www.driveweb.com


drive.web automation

smarty I/O Four Removable Terminal Blocks  

smarty I/O Four Removable Terminal Blocks cont’d. 
Terminal wiring - Strip 7mm(0.28”) or use ferrules. Use 

0.2mm2 (AWG24) minimum. One wire, 2.5mm2 (AWG12) 
maximum.  Two wires, 1.5mm2(AWG14) maximum. Two 
wires with ferrules, 1mm2 (AWG18) maximum. 

Terminal tightening torque - 0.5 Nm (4.4 in⋄lbs). 
24VDC and 0V Terminals are internally connected. 

Regulated 24VDC ±5%, 100mA plus loads.   
Do not connect to a distributed DC power network.  
External 1A fast-acting fuse or current-limiting is 

required!  
Supply from Class 2, LPS, limited power supply only. 

I/O Ratings including ±10Vrefs  
Use shielded cable for runs over 30 meters. 
Fast transient over-Voltage 1kV per EN 61000-4-4. 

±10Vrefs +13V max, -13V min, 20mA source and sink. 
I/AO Terminals T13-T16 and T19-T22 +25V max, -13V 

min, 100kΩ input impedance. Bipolar Analog Output, 
Bipolar Analog Input and/or Digital Input. 

I/DO Terminals T23-T24 and T27-T32 +25V max, -0.6V 
min, 100kΩ input impedance. 24V Digital Output, 
Unipolar Analog Input and/or Digital Input.  

Warning! To avoid damaging smarty, do not apply 
low-impedance source to any I/DO terminals 
when smarty is powered off. A series 10kΩ 
isolation resistor is required.  

smarty Serial Port Connections
Drive-dedicated models include a “plug and play” serial cable. 

The serial port replaces I/O terminals T1, T2. 
See separate product manual, HG502421, for dw210 serial 

port information and bus-sharing the dedicated serial port.  

T1 T2 T3 T4 T5 T6 T7 T8
24VDC 0V Option dependent. See pages 11, 12 for more info.

T9 T10 T11 T12 T13 T14 T15 T16
24VDC 0V +10Vref -10Vref I/AO I/AO I/AO I/AO

T17 T18 T19 T20 T21 T22 T23 T24
24VDC 0V I/AO I/AO I/AO I/AO I/DO I/DO

T25 T26 T27 T28 T29 T30 T31 T32
24VDC 0V I/DO I/DO I/DO I/DO I/DO I/DO
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Drive Setup Notes

dw213 Optidrive Plus notes
Check drive model number and firmware version. P0-28 

and P0-29 should indicate 2.2 or higher. Model number 
must end in -M for firmware versions prior to 3.0. 

dw215 Yaskawa YF7 notes 
Check Flash ID, U1-14 = 3020.  
Check internal line termination switch S1-1. 
Cycle YF7 power, wait for screen to blank 

before re-powering, for parameter 
changes to take effect. 

Set up your computer - Get savvy 
With free drive.web savvy software, easily program and 

monitor your smarty, perform data trending, and create 
distributed control systems. 

Go to www.driveweb.com and click on Get savvy, or 
contact us to get the latest version of  savvy. 

smarty USB - Plug and Play 
Experience plug-and-play access to smarty and its local 

Ethernet network. Requires 0x201A firmware or later. 
smarty Ethernet Networking & Programming 
Assigning an invalid or duplicate IP address will cause serious 

network malfunctions!  
Find useful networking information. Under the Help menu 

click on Getting Started with savvy section.  
smartys are all shipped with the IP address, 10.189.189.189. 
Use Category 5e cable or better, with 8P8C/RJ-45 connectors 

for each drive.web  device and the host computer. 
For systems with more than one drive.web device, use an 

Ethernet switch for all drive.web devices and computer.  

smarty 
model

Supported 
drive Required drive settings Related drive 

settings
Cable 

Assembly
dw210 Generic Baud-rate, framing Serial loss behavior Not 

Available
dw212 OptidriveE2 P-36; Address = 1, 

Baud rate= 115.2kbps
P-36, Comms Loss 
Trip Enable LA503108

dw213 Optidrive 
Plus

P2-26, Baudrate = 115.2kbps 
P2-27, Address = 1

P2-26, T, trip or R, 
ramp on serial loss LA503066

dw215 YaskawaF7
H5-01 = 1F, decimal 31 
H5-02 = 4, 19.2kbps 
H5-03 = 00, No parity 
H5-06 = 05, Min. delay 5ms

H5-04 Stopping 
Method 
H5-05 Serial Fault 
Detect

LA503124

dw216 Optidrive 
HVAC

P-36; Address = 1, 
Baud rate= 115.2kbps

P-36, Comms Loss 
Trip Enable LA503108
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Get started with savvy 
We strongly recommend attending our free online 

training seminars. See page 12. 
We strongly recommend you read the User Manual 

and Getting Started Guides under the Help menu.    
Use Create Phantom in the Directory menu to 

explore drive.web products and options, design, 
and configure offline. Export Data to save your 
work. Import Data into  phantoms to work offline.  

savvy Window Title Bar indicates the current view. 

Status Bar, above the viewing area, provides Navigation 
Arrows and object and location data. 

savvy views are hierarchical with the Device Directory 
View at top. Use the Navigation Arrows to go up, back, 
or forward. Window menus change as you navigate.  

Hover cursor over active object, device, function block, 
connection, or parameter icon to view object information 
in the Status Bar and reveal a Hover Button. 

Click a Hover Button or right-click an active object to 
access a Contextual Menu. See below. 

savvy functions are limited by password-protected 
capability level . See File > Capability... 

Device Directory Window  

Warning! Changing a device IP address WILL disrupt its 
network connections! If  a smarty is communicating with 
other devices, be prepared for system disruption. In the 
File menu choose Utility > Remap Export File to 
remap a dw-system file with different IP address(es). 

Select File>Administrate>Set IP Addresses for System.   
smarty serial number is also its MAC Address.  
Enter a valid IP address and click OK.   

An icon appears with IP address beneath. Drive-dedicated 
models depict the actual frame size of  the drive. 

If  the icon at right appears, a network connection problem 
exists. Check connections, LEDs, and that the smarty  
IP address is within the computer’s Ethernet subnet mask.   

Warning! Importing data into your smarty will result in 
immediate execution of  that configuration. Dangerous 
Voltages and rotating machinery may result! Use 
a phantom to preview a configuration. 

Directory > Import / Export Data. All device configurations and 
connections in the directory in one .dw-system file.  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Get started with savvy continued... 
smarty Icon Contextual Menu  

Change Name - Name your smarty for easy identification.  
Import / Export Device Data... - Load / save 

configuration data to / from this smarty only. 
Unlock, Lock, Set Password - Choose Restrict 

Modification to allow viewing the configuration, or 
Restrict All Access. 

Click the smarty icon to view the device configuration. 
Function Block Engine Window - FBE Menu 
(Standard savvy, no SFD) 

Add function blocks in the order to be processed. Processing 
order is left to right, top to bottom. 

Click function blocks to view parameters and details.  
Connect between parameters and other drive.web devices.  
Warning! Making a connection results in immediate 

execution of  that connection. Dangerous Voltages and 
rotating machinery may result! 

Under the File menu, choose New Viewer... and then, 
File > Open Device Directory.  

With two viewer windows, click a parameter, drag and 
drop onto a parameter in the other viewer.    

Parameter Contextual Menu - Most parameter data is 16-
bit. Data is formatted, limited, and scaled depending on the 
parameter. Use Get Info or Re-Scale... to verify or change. 

Click parameters for the Setter Box - Increment, 
decrement, default, last state, or keyboard entry. 

Click blue connection block or arrow to jump to other end. 

Upgrade savvy and smarty 
Upgrade savvy with SFD Signal Flow Diagram.  
Upgrade smarty with software options.  
Process credit cards or Vouchers online or Coupons offline.  

To upgrade savvy go to the Commerce menu, select 
Upgrade savvy, check desired options, click OK. 

To upgrade smarty, choose Upgrade Device… in its 
contextual menu, check desired options, click OK. 

To process Vouchers, choose Pay>Online Via Vouchers 
in the Shopping Cart. Enter Voucher codes on separate 
lines. 

To process Coupons, go to the Commerce menu and 
choose Coupon Manager. Enter codes in the top box 
and click the Add button and the coupon is recognized. 
Click Apply. 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savvy-SFD Signal Flow Diagram Upgrade 
With savvy-SFD, build systems graphically. The live 

drawings are stored in your smarty.   
Set drawing borders and annotate multi-page drawings.  
A filterable list of  function blocks and connections is at the 

left of  the Signal Flow Diagram showing program 
execution order from top down. Change execution 
order by dragging function blocks up or down the list. In 
this picture, ENC1 Speed function block is moved so that 
it is processed after ENC Phase Lock. 

savvyPanel Operator Station
Computers, Apple® mobile digital devices; iPad®, iPhone®, 

and iPod Touch® are operator touch stations with 
savvyPanel. Requires Windows(XP, Vista, 7), Mac OS 
X, Linux-based Ubuntu, or iOS®. 

Configurations are stored in the drive.web devices. 
savvy-SFD upgrade is required to edit or build 

savvyPanel systems. 
dwOption-26 savvyPanel, must be installed in 

drive.web devices to enable the full suite of  tiles. A 
limited set is available without the option.  

Get savvyPanel free from the Apple App Store℠
When your iPad or iPhone is connected to the internet via 

WiFi, demo mode connects to a live drive system in our 
plant in Maryland, USA. 

Explore the demo with savvy. Select File menu> Demo 
Mode > Discover Internet Demo Devices. 

savvyPanel Pages
Systems Page where multiple savvyPanel systems are present.  

A savvyPanel system may contain tiles from many drive.web devices.  
A drive.web device contributes to only one savvyPanel system. 
Touch the systems button,      or     , in the window bar to 

access the systems page from home page. Lock this button 
with home password. 

Home Page is the first operator page in a savvyPanel system. 
Access home page from any operator page with the home 

button,     . Lock with the home password. 
Operator Pages show graphic, page-link, and parameter tiles.  

Pages can be renamed. Page name appears in window title bar. 

savvyPanel Tiles
Parameter Tiles - Touch a settable parameter to set. Setter 

includes slider, keypad, 1x and 10x increment and 
decrement, return-to-default, and revert.  

Graphic Tiles - Create diagrams with process elements. 
Page-Link Tiles - A graphic tile that is also a page-link.  

Touch to change the view to that page.
Device Tiles - Link to device’s signal flow diagram in Java-

based savvyPanel. Appears as graphic tile in iOS.  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Function blocks enable savvyPanel actions
Alarm Annunciator - Provides a system-wide alarm 

annunciation when active. Touch to view page 255. 
Presence Monitor - Indicates the presence of  a tagged 

savvyPanel application viewing a particular page. 
Latch and SR Latch - For lighted start-stop pushbuttons.  
Setpoint & Monitor - Adjust meter and setter range. Dual 

blocks enable dual-display meters. 
Enumerated Parameter - In Utility group. Only custom 

enumerations appear in the setter and multi-position switch. 

savvyPanel Launch, Setup, and Important Notes
See the savvy user manual for detailed instructions. 
Launch savvyPanel via command line or batch file.  
Limit operators to savvyPanel only. Specify start system and page. 
Discover devices automatically, specifically by discovery file, 

or filtered by group and/or savvyPanel name. 
Operator’s note: If  communication with a drive.web 

device is interrupted, affected tiles indicate a yellow bar 
with a warning symbol. The tile is not updated. 

dw215 YF7-native parameters are not supported. Connect 
to function block engine for savvyPanel. 

Important Design Note - An over-range enumeration is 
required if  an out-of-range value could cause a hazard. 

smarty Flexible Analog & Digital I/O Blocks
Analog Input Function Block - 16-bit resolution. 

Available for all I/AO and I/DO terminals. 
4-20mA Input Example - Connect external resistor, R, 

100Ω to 500Ω, to a 0V terminal.  
Offset = -25%, Scaling = 0.016 * RΩ. 

Digital Input Function Block
Available for all I/AO and I/DO.
Selectable ranges 5V, 12V, & 24V. 

Analog Output Function Block
Available for all I/AO terminals. 
±10.5V, 10mA max output.  

Digital Output Function Block
Available for all I/DO terminals. 
+24V, 50mA max. Enable Source and/or Sink.   
Source drivers shut down in case of  overheating or over-

current. A warning triangle appears in the function 
block and its Source Status parameter indicates 
Fault. Click Source Status for a Reset button. 
Also, a Reset function block in the I/O (1) list set. 
Note! Resetting a digital output briefly resets all I/O! 

Warning! Avoid permanent damage to smarty. When 
Sink Enable is active, that terminal MUST be 
impedance-protected, current-limited, or fuse-
protected with a fast acting 0.1A fuse. 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Digital 
Input Range

Turn-On 
Threshold

Turn-Off  
Threshold

5V 2.5V 0.83V
12V 6V 2V
24V 12V 4V
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smarty Internal Hardware Options 

Serial ports LEDs in smarty front panel. 

Data received and transmitted at Ports 1 and 2 with serial 
port options, 17 to 23.  

Encoder options, 15, 16, 18, 22, and 23, transmit i2i data to 
Port 2. Receive LED is always lit with option 15 or when 
remote encoder module is powered-up and connected.  

Custom LED control with options 24, 27, 28, 37, and 38. 
Find LED Control block in the I/O (1) list set. 

Signal Wiring Notes  

Use twisted-pair wiring for encoder and serial differential signals.  

Outside metal enclosure, use shielded cable with individually 
shielded twisted-pairs such as Belden 8163. Ground 
shield at one end with a 360° ground clamp where cable 
enters “quiet” metal enclosure.  

Separate wiring from AC power cables or RF noise sources. 

dwOption-15 Internal Incremental Encoder
Encoder isolated supply output, +5Vi, 200mA max.  

If  encoder is powered from a different source, a 
connection from that 0V to T8 0Vi, is required. 

Differential inputs are ±2V to ±24V max, up to 500kHz max. 

Status parameter must read OK. Other 
indications result in speed Output = 0.00 
%.  Faults are listed at right.  

Comms Fault or Comms Errors may result 
from overloading +5Vi, extreme RF noise 
coupling, or a hardware fault.  

A filter in ENC1 Speed function block reduces 
quantization noise. Higher PPR encoders or speeds allow 
smaller filter size. Default, 15, provides filter size = 15 ⋄ 
4.78ms. 

dwOption-16 i2i External Encoder(s) on Port 2 

Intelligent 2-wire Interface receiver. Unpolarized & isolated, 
1000’ max., for dwOption-40 or -42, External Encoder 
Module. See separate manual, HG502613. 

dwOption-24 Add Six Digital Inputs at T3-T8
+25V max, -0.6V min, 8.2kΩ input impedance.  

See page 10 for Digital Input function block and threshold info. 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Encoder Fault Detection
Short Circuit or Open Circuit

-10V<V Common Mode<13.2V

|Vdifferential| < 275~475mV

Serial Port LEDs 
Receive Transmit
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smarty Comms Interfaces-Modbus & EIP/PCCC
Warning! Use of  smarty comms interfaces, ModbusTCP, 

ModbusRTU, and EIP/PCCC, may cause motors and 
machinery to energize with high Voltages, or start, or 
operate in an unexpected, dangerous, or lethal way. 

For Modbus specs go to http://modbus.org/specs.php 

smarty Comms Server dwOption-04, -17, -18, & -25 
Note! You cannot write or force parameters that are read-

only or have incoming drive.web connections. 
Click the Comms Server icon in the FBE or SFD view. 

dwOption-04 ModbusTCP/IP slave/server
Supported Modbus Function Codes; 1 thru 6, 15, and 16. 
Supports up to five simultaneous clients/masters.  

dwOption-25 EIP/PCCC Server
Supports PLC5 Typed-Write and Typed-Read commands. 
See Appendix B of  the savvy User Manual for information 

and drive.web parameter IDs mapping to PLC5. 
Supports up to two simultaneous clients. 

smarty Option Manuals Available Online  
Go to the Get savvy page at driveweb.com and scroll to the bottom. 
dwOption-17 to -23  ModbusRTU Product manual HG502421. 

Dual serial ports. Bus-sharing and networking information. 
dwOption-27  Frequency IO Product manual, HG503056. 

Input frequencies 1Hz to 100kHz. Outputs 10Hz to 20kHz. 
dwOption-30 & -31 High Voltage Digital I/O Product manual HG502622. 

Two 3A, NO relay contacts, 4 opto-isolated AC digital inputs. 
dwOption-37, -38 Dual Stepper Controller Product manual, HG503431. 

5V Step and Direction Outputs, up to 500kHz. 
High-speed event inputs or i2i remote encoder module input. 

dwOption-40 to -46 External Encoder Module Product manual, HG502613. 
Dual encoders with retransmit for electronic line-shaft, registration, etc. 

drive.web Training Courses  
Free online interactive training seminars take about one hour.  
Specialized online and factory training sessions are also 

available.  
To register email training@driveweb.com or call.
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